Doremi server content not detected on AAM Screenwriter

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • Ilmiawan Malik
    Newbie
    • Dec 2025
    • 3
    • Bogor, Indonesia

    #1

    Doremi server content not detected on AAM Screenwriter

    Recently I got this error on my screenwriter that two of my server which is doremi showvaulth, the error says "_device_sync_content_information: KeyError('cpl_id',)

    There is 8 screen on my site but 2 of them (Screen 2 & 3) have that error on the screenwriter, I already delete and add back the screen server configuration on the screenwriter but thats not changing anything, change the LAN cable from the Doremi showvault to the switch still not working, ping-ing is okay, and the content is just fine if I check on the Doremi server directly. How to solve this?

    This is the picture of the error:
    1000110944.jpg

    This is my first post on the forum, so I hope you guys understand what im trying to describe, many thanks!!
  • Caleb Williams
    Pro Film Handler
    • Jun 2022
    • 149
    • Casper, Wyoming, USA

    #2
    Welcome to the forum!

    Are all of the screen servers the same type at this location?

    Other than deleting and re-adding 2 & 3 to screenwriter, were any other configuration changes made recently?

    When was the last time the Server running Screenwriter was fully rebooted?

    That error might indicate that Screenwriter expects some content to exist on the Doremi server, but when the request is made the Doremi server is sending some strange information back.

    Comment

    • Ilmiawan Malik
      Newbie
      • Dec 2025
      • 3
      • Bogor, Indonesia

      #3
      Yes, all the screen servers at my location are all the same, actually the server that running the screenwriter always get shutdown when all shows is over that means it gets rebooted everyday right?

      there is no configuration change recently, its just turn red all of the sudden, first the screen 3, not long after the screen 2 also turn red

      do you have any tips on how to solve this? thankyou
      Last edited by Ilmiawan Malik; 12-13-2025, 04:10 AM.

      Comment

      • Frank Cox
        Film God
        • Jan 2020
        • 2314
        • Melville Saskatchewan

        #4
        I know nothing about the AAM Screenwriter, but I wonder if the time is synchronized between all of your servers/projectors/etc.

        Comment

        • Caleb Williams
          Pro Film Handler
          • Jun 2022
          • 149
          • Casper, Wyoming, USA

          #5
          Originally posted by Ilmiawan Malik
          do you have any tips on how to solve this? thankyou
          Does that error effect scheduling/playback/content-management?
          ​
          You mentioned that the Screenwriter server gets restarted nightly. Does it get shut down gracefully or just by flipping a switch? You may be dealing with some database corruption if the latter is the case.

          I would approach this issue by first collecting logs from the Doremi servers, and upload them to https://loganalyzer.dolbycustomer.com. You don't need a customer account to use that tool, and it should help rule out any potential issues on the Doremi side.

          I'm not familiar with the showvault servers, but the IMS series had a tool to clear out "orphaned packages", or content that was only partially deleted. You might see if your Showvaults have a similar tool, and see if that clears the error on Screenwriter after it has had a chance to sync again.

          If the logs don't produce any negative results and there is no issue with content, your next step would be to reach out to the integrator who installed Screenwriter. There is a service account where they can collect logs and send them to AAM.





          Comment

          Working...